Windows 7 error: The trust relationship between this workstation and the primary domain failed

I got a new DELL laptop with OEM Microsoft Windows 7 Professional SP1 x64 installed on the system. All was good almost 2 weeks and all worked very nice. Computer was joined to Active Directory on Microsoft Small Business Server 2008 Premium and there were no issues. Computer was taken off the network for few days due a business trip. Today returned, plugged in on the wire and try to log on to the domain and this message is occupying my screen:

Windows 7 Error

Windows 7 login screen error

 

 

 

 

 

 

Wow, that is something new that I never seen before and I have few computers with Windows 7 Professional x64 on the network now for several months. What is very interesting I cannot log on to the machine as long as the network cable is plugged in. Once I have disconnected the cable from laptop, I was able to logon to domain as well as a local user.

Solution to this problem:

  • Disconnect cable from the machine
  • Log on
  • Unjoin and join back the computer to the domain
  • Once rejoined to domain all works again

I have also researched on different forums on this issue and apparently there is a hotfix for this issue provided by Microsoft KB976494. In case anyone knows answer to this why this happening or solved it different way, let me know in comments.

 

Be the first to comment on "Windows 7 error: The trust relationship between this workstation and the primary domain failed"

Leave a comment

Your email address will not be published.


*


Get Adobe Flash player Plugin by wpburn.com wordpress themes